
Hello, Android: Quickstart

Introduction to Android development with Xamarin

Hello, Android Quickstart

In this walkthrough, you will create an application that translates an alphanumeric phone number (entered by the

user) into a numeric phone number and then calls that number. The final application looks like this:

Requirements

To follow along with this walkthrough, you will need the following:

[[ide name="vs"]]

Windows 7 or later

Visual Studio 2012 Professional or later
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[[ide name="xs"]]

The latest version of Xamarin Studio

OS X Yosemite or later (if you are using a Mac)

Windows 7 or later (if you are using a PC)

[[/ide]]

This walkthrough assumes that the latest version of Xamarin.Android is installed and running on your platform of

choice. For a guide to installing Xamarin.Android, refer to the Xamarin.Android Installation guides. Before you get

started, please download and unzip the Xamarin App Icons & Launch Screens set.

Configuring Emulators

If you are using Google's Android SDK emulator, we recommend that you configure the emulator to use

hardware acceleration. Instructions for configuring hardware acceleration are available in Accelerating Android

Emulators with HAXM.

[[ide name="vs"]]

If you are using the Visual Studio Android Emulator, Hyper-V must be enabled on your computer. For more

information about configuring the Visual Studio Android Emulator, see System Requirements for the Visual

Studio Emulator for Android.

[[/ide]]

Walkthrough

[[ide name="vs"]]

1. Start Visual Studio:

/guides/android/getting_started/installation/
/guides/android/getting_started/hello,android/Resources/XamarinAppIconsAndLaunchImages.zip
/guides/android/getting_started/installation/accelerating_android_emulators
/guides/android/getting_started/installation/accelerating_android_emulators
https://msdn.microsoft.com/en-us/library/mt228280.aspx
https://msdn.microsoft.com/en-us/library/mt228280.aspx
Images/vs/01-launch-sml.png


2. Click Start > New Project to create a new project:

3. In the New Project dialog, click Visual C# > Android and select the Blank App (Android) template.

Name the new project Phoneword. Click OK to create the new project:

Images/vs/01-launch-sml.png
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4. After the new project is created, expand the Resources folder and then the layout folder in the Solution

Explorer. Double-click Main.axml to open it in the Android Designer. This is the layout file for the screen:

5. Select the Hello World, Click Me! Button on the design surface and press the Delete key to remove it.

From the Toolbox (the area on the left), enter text into the search field and drag a Text (Large) control

onto the design surface (the area in the center):

Images/vs/03-new-project-name-sml.png
Images/vs/04-open-layout-sml.png
Images/vs/05-large-text-sml.png


6. With the Text (Large) control selected on the design surface, you can use the Properties pane to change

the text property of the Text (Large) control to Enter a Phoneword: as shown here:

7. Drag a Plain Text widget from the Toolbox to the design surface and place it underneath the Text (Large)

widget. Notice that you can use the search field to help locate widgets by name:

8. With the Plain Text control selected on the design surface, you can use the Properties pane to change the
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id property of the Plain Text control to @+id/PhoneNumberText and change the text property to 1-

855-XAMARIN:

9. Drag a Button from the Toolbox to the design surface and place it underneath the Plain Text widget:

10. With the Button selected on the design surface, you can use the Properties pane to change the id

property of the Button to @+id/TranslateButton and change the text property to Translate:

Images/vs/08-add-properties-sml.png
Images/vs/09-drag-button-sml.png


11. Drag a second Button from the Toolbox to the design surface and place it underneath the Translate

button:

12. With the new Button control selected on the design surface, you can use the Properties pane to change

the id property of the Button to @+id/CallButton and change the text property to Call:

Images/vs/10-translate-button-sml.png
Images/vs/11-drag-call-button-sml.png
Images/vs/12-call-properties-sml.png


Save your work by pressing CTRL+S.

13. The next step is to add some code to translate phone numbers from alphanumeric to numeric. Add a new

file to the project by right-clicking the Phoneword project in the Solution Explorer pane and choosing Add

> New Item...:

Images/vs/12-call-properties-sml.png
Images/vs/13-add-new-item-sml.png


14. In the Add New Item dialog, select Visual C# > Code and name the new code file PhoneTranslator.cs:

15. This creates a new empty C# class for us. Remove all of the template code and replace it with the following

code:

using System.Text;

using System;

namespace Core

{

    public static class PhonewordTranslator

    {

        public static string ToNumber(string raw)

        {

            if (string.IsNullOrWhiteSpace(raw))

                return "";

            else

                raw = raw.ToUpperInvariant();

            var newNumber = new StringBuilder();

            foreach (var c in raw)

            {

                if (" -0123456789".Contains(c))

                    newNumber.Append(c);

                else {

                    var result = TranslateToNumber(c);
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Images/vs/14-add-class-sml.png


                    if (result != null)

                        newNumber.Append(result);

                }

                // otherwise we've skipped a non-numeric char

            }

            return newNumber.ToString();

        }

        static bool Contains (this string keyString, char c)

        {

            return keyString.IndexOf(c) >= 0;

        }

        static int? TranslateToNumber(char c)

        {

            if ("ABC".Contains(c))

                return 2;

            else if ("DEF".Contains(c))

                return 3;

            else if ("GHI".Contains(c))

                return 4;

            else if ("JKL".Contains(c))

                return 5;

            else if ("MNO".Contains(c))

                return 6;

            else if ("PQRS".Contains(c))

                return 7;

            else if ("TUV".Contains(c))

                return 8;

            else if ("WXYZ".Contains(c))

                return 9;

            return null;

        }

    }

}

Save the changes to the PhoneTranslator.cs file by clicking File > Save (or by pressing CTRL+S), then

close the file. Ensure that there are no compile-time errors by rebuilding the solution.

16. Next, add code to wire up the user interface by inserting backing code into the MainActivity class.

Double-click MainActivity.cs in the Solution Explorer to open it:

Images/vs/16-mainactivity-sml.png


17. Begin by wiring up the Translate button. In the MainActivity class, find the OnCreate method. Add the

button code inside OnCreate, below the base.OnCreate(bundle) and SetContentView

(Resource.Layout.Main) calls. Remove the template button handling code so that the OnCreate

method resembles the following:

using System;

using Android.App;

using Android.Content;

using Android.Runtime;

using Android.Views;

using Android.Widget;

using Android.OS;

namespace Phoneword

{

    [Activity (Label = "Phoneword", MainLauncher = true)]

    public class MainActivity : Activity

    {

        protected override void OnCreate (Bundle bundle)

        {

            base.OnCreate (bundle);

            // Set our view from the "main" layout resource

            SetContentView (Resource.Layout.Main);
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            // Our code will go here

        }

    }

}

18. Get a reference to the controls that were created in the layout file via the Android Designer. Add the

following code inside the OnCreate method, after the call to SetContentView:

// Get our UI controls from the loaded layout:

EditText phoneNumberText = FindViewById<EditText>(Resource.Id.PhoneNumberText);

Button translateButton = FindViewById<Button>(Resource.Id.TranslateButton);

Button callButton = FindViewById<Button>(Resource.Id.CallButton);

19. Add code that responds to user presses of the Translate button. Add the following code to the OnCreate

method (after the lines added in the last step):

// Disable the "Call" button

callButton.Enabled = false;

// Add code to translate number

string translatedNumber = string.Empty;

translateButton.Click += (object sender, EventArgs e) =>

{

    // Translate user's alphanumeric phone number to numeric

    translatedNumber = Core.PhonewordTranslator.ToNumber(phoneNumberText.Text);

    if (String.IsNullOrWhiteSpace(translatedNumber))

    {

        callButton.Text = "Call";

        callButton.Enabled = false;

    }

    else

    {

        callButton.Text = "Call " + translatedNumber;

        callButton.Enabled = true;

    }

};

20. Add code that responds to user presses of the Call button. Place the following code below the code for the

Translate button:



callButton.Click += (object sender, EventArgs e) =>

{

    // On "Call" button click, try to dial phone number.

    var callDialog = new AlertDialog.Builder(this);

    callDialog.SetMessage("Call " + translatedNumber + "?");

    callDialog.SetNeutralButton("Call", delegate {

           // Create intent to dial phone

           var callIntent = new Intent(Intent.ActionCall);

           callIntent.SetData(Android.Net.Uri.Parse("tel:" + 

translatedNumber));

           StartActivity(callIntent);

       });

    callDialog.SetNegativeButton("Cancel", delegate { });

    // Show the alert dialog to the user and wait for response.

    callDialog.Show();

};

21. Finally, it's time give the application permission to place a phone call. App permissions can be edited in the

Android Manifest. In the Solution Explorer, open the Android Manifest by double-clicking Properties

under Phoneword, then select the Android Manifest page:
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Under Required Permissions, enable the CALL_PHONE permission:

22. Save your work by selecting File > Save All (or by pressing CTRL-SHIFT-S) and build the application by

selecting Build > Rebuild Solution (or by pressing CTRL-SHIFT-B). If the application compiles, you will

get a success message in the bottom left corner of Visual Studio:

If there are errors, go through the previous steps and correct any mistakes until the application builds

successfully. If you get a build error such as, Resource does not exist in the current context, verify that the

namespace name in MainActivity.cs matches the project name (Phoneword) and then completely rebuild

the solution. If you still get build errors, verify that you have installed the latest Xamarin.Android updates.

23. You should now have a working application – it's time to add the finishing touches! Edit the Label for the

MainActivity. The Label is what Android displays at the top of the screen to let users know where they

are in the application. At the top of the MainActivity class, change the Label to Phone Word as

shown here:

namespace Phoneword

{

    [Activity (Label = "Phone Word", MainLauncher = true)]

    public class MainActivity : Activity

Images/vs/21b-call-phone-sml.png
Images/vs/22-rebuild-all-succeeded.png


    {

        ...

    }

}

24. Next, set the application icon. First, download and unzip the Xamarin App Icons set. Next, expand the

drawable folder under Resources and remove the existing Icon.png by right-clicking it and selecting

Delete:

When the following dialog box is displayed, click OK:

/guides/android/getting_started/hello,android/Resources/XamarinAppIconsAndLaunchImages.zip
Images/vs/24a-delete-icon-sml.png
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25. Next, right-click the drawable folder and select Add > Existing Item...:

26. From the selection dialog, navigate to the unzipped Xamarin App Icons directory and open the drawable

folder. Select Icon.png and click Add:

Images/vs/24b-icon-deleted-permanently.png
Images/vs/25-add-existing-item-sml.png
Images/vs/26-select-icon-sml.png


27. Next, add the rest of the Xamarin App Icons drawable- folders to the project. These folders provide

different resolutions of the icon so that it renders correctly on different devices with different screen

densities. In a File Explorer window, navigate to the unzipped Xamarin App Icons directory and select the

drawable- folders:

Drag these folders onto the Resources folder in the Visual Studio Solution Explorer pane. These folders

are now part of the project as shown in Solution Explorer on the right:
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28. Specify the icon in the Android Manifest by choosing @drawable/Icon from the Application Icon drop-

down menu:

29. Finally, you can test your application by deploying it to an emulator. In this example, a virtual device called

Nexus 5 (KitKat) is used; this virtual device was configured via the Android AVD Manager (as explained in

Android SDK Emulator). However, you can use one of the pre-configured devices available in the device

drop-down menu.

Before you send your app to this emulator, configure the app's minimum Android version so that it will run
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on your chosen virtual device. In Visual Studio, open the Application page of Properties. Under Minimum

Android to target:, set the API level to match the API level of the virtual device you are using. In this

example, API Level 19 was selected so that the app will run on the Nexus 5 (KitKat) virtual device. (For

more information about Android API levels, see Understanding Android API Levels).

30. Next, deploy the app to the device from the drop-down menu on the toolbar as shown here:

Visual Studio will copy files to this emulator before installing and launching the app.

31. The screenshots below illustrate the Phoneword application running in the Android SDK Emulator. Clicking

the Translate button updates the text of the Call button, and clicking the Call button causes the call dialog

to appear as shown on the right:

/guides/android/application_fundamentals/understanding_android_api_levels/
Images/vs/29c-set-api-level-sml.png
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1. Launch Xamarin Studio from the Applications folder or from Spotlight. This opens the start page:
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2. Click New Solution... to create a new project:

3. In the Choose a template for your new project dialog, click Android > App and select the Android App

template. Click Next.
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4. In the Configure your Android app dialog, name the new app Phoneword and click Next:

5. In the Configure your new project dialog, leave the Solution and Project names set to Phoneword and

click Create to create the project.

Be sure to uncheck the checkboxes for Xamarin Insights and Xamarin Test Cloud:

Images/xs/04-configure-app-sml.png
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/guides/testcloud/uitest/intro-to-uitest/
Images/xs/05-configure-project-sml.png


6. After the new project is created, expand the Resources folder and then the layout folder in the Solution

pad. Double-click Main.axml to open it in the Android Designer. This is the layout file for the screen:

7. Select the Hello World, Click Me! Button on the design surface and press the Delete key to remove it.

From the Toolbox (the area on the right), enter text into the search field and drag a Text (Large) widget

onto the design surface (the area in the center):
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8. With the Text (Large) widget selected on the design surface, you can use the Properties pad to change

the Text property of the Text (Large) widget to Enter a Phoneword: as shown below:

ℹ️ Note: You can bring up the Properties pad or Toolbox at any time by navigating to View >

Pads.

1. Next, drag a Plain Text widget from the Toolbox to the design surface and place it underneath the Text

(Large) widget. Notice that you can use the search field to help locate widgets by name:

2. With the Plain Text widget selected on the design surface, you can use the Properties pad to change the
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Id property of the Plain Text widget to @+id/PhoneNumberText and change the Text property to 1-

855-XAMARIN:

3. Drag a Button from the Toolbox to the design surface and place it underneath the Plain Text widget:

4. With the Button selected on the design surface, you can use the Properties pad to change the Id

property of the Button to @+id/TranslateButton and change the Text property to Translate:
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5. Next, drag a second Button from the Toolbox to the design surface and place it underneath the Translate

button:

6. With the Button selected on the design surface, you can use the Properties pad to change the Id

property of the Button to @+id/CallButton and change the Text property to Call:
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Save your work by pressing ⌘⌘ + S.

7. Now, add some code to translate phone numbers from alphanumeric to numeric. Add a new file to the

project by clicking the gear icon next to the Phoneword project in the Solution pad and choosing Add >

New File...:

8. In the New File dialog, select General > Empty Class, name the new file PhoneTranslator, and click

New:
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9. This creates a new empty C# class for us. Remove all of the template code and replace it with the following

code:

using System.Text;

using System;

namespace Core

{

    public static class PhonewordTranslator

    {

        public static string ToNumber(string raw)

        {

            if (string.IsNullOrWhiteSpace(raw))

                return "";

            else

                raw = raw.ToUpperInvariant();

            var newNumber = new StringBuilder();

            foreach (var c in raw)

            {

                if (" -0123456789".Contains(c))

                    newNumber.Append(c);

                else {

                    var result = TranslateToNumber(c);

                    if (result != null)

                        newNumber.Append(result);

                }

                // otherwise we've skipped a non-numeric char

            }
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            return newNumber.ToString();

        }

        static bool Contains (this string keyString, char c)

        {

            return keyString.IndexOf(c) >= 0;

        }

        static int? TranslateToNumber(char c)

        {

            if ("ABC".Contains(c))

                return 2;

            else if ("DEF".Contains(c))

                return 3;

            else if ("GHI".Contains(c))

                return 4;

            else if ("JKL".Contains(c))

                return 5;

            else if ("MNO".Contains(c))

                return 6;

            else if ("PQRS".Contains(c))

                return 7;

            else if ("TUV".Contains(c))

                return 8;

            else if ("WXYZ".Contains(c))

                return 9;

            return null;

        }

    }

}

Save the changes to the PhoneTranslator.cs file by choosing File > Save (or by pressing ⌘⌘ + S), then

close the file. Ensure that there are no compile-time errors by rebuilding the solution.

10. The next step is to add code to wire up the user interface by adding the backing code into the

MainActivity class. Double-click MainActivity.cs in the Solution Pad to open it:
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11. Begin by wiring up the Translate button. In the MainActivity class, find the OnCreate method. Add the

button code inside OnCreate, below the base.OnCreate(bundle) and SetContentView

(Resource.Layout.Main) calls. Remove the template button handling code so that the OnCreate

method resembles the following:

using System;

using Android.App;

using Android.Content;

using Android.Runtime;

using Android.Views;

using Android.Widget;

using Android.OS;

namespace Phoneword

{

    [Activity (Label = "Phoneword", MainLauncher = true)]

    public class MainActivity : Activity

    {

        protected override void OnCreate (Bundle bundle)

        {

            base.OnCreate (bundle);

            // Set our view from the "main" layout resource

            SetContentView (Resource.Layout.Main);

            // Our code will go here

        }
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    }

}

12. Next, a reference is needed to the controls that were created in the layout file with the Android Designer.

Add the following code inside the OnCreate method (after the call to SetContentView):

// Get our UI controls from the loaded layout:

EditText phoneNumberText = FindViewById<EditText>(Resource.Id.PhoneNumberText);

Button translateButton = FindViewById<Button>(Resource.Id.TranslateButton);

Button callButton = FindViewById<Button>(Resource.Id.CallButton);

13. Add code that responds to user presses of the Translate button by adding the following code to the

OnCreate method (after the lines added in the last step):

// Disable the "Call" button

callButton.Enabled = false;

// Add code to translate number

string translatedNumber = string.Empty;

translateButton.Click += (object sender, EventArgs e) =>

{

    // Translate user's alphanumeric phone number to numeric

    translatedNumber = Core.PhonewordTranslator.ToNumber(phoneNumberText.Text);

    if (String.IsNullOrWhiteSpace(translatedNumber))

    {

        callButton.Text = "Call";

        callButton.Enabled = false;

    }

    else

    {

        callButton.Text = "Call " + translatedNumber;

        callButton.Enabled = true;

    }

};

14. Add code that responds to user presses of the Call button. Place the following code below the code for the

Translate button:

callButton.Click += (object sender, EventArgs e) =>

{

    // On "Call" button click, try to dial phone number.



    var callDialog = new AlertDialog.Builder(this);

    callDialog.SetMessage("Call " + translatedNumber + "?");

    callDialog.SetNeutralButton("Call", delegate {

           // Create intent to dial phone

           var callIntent = new Intent(Intent.ActionCall);

           callIntent.SetData(Android.Net.Uri.Parse("tel:" + 

translatedNumber));

           StartActivity(callIntent);

       });

    callDialog.SetNegativeButton("Cancel", delegate { });

    // Show the alert dialog to the user and wait for response.

    callDialog.Show();

};

15. Finally, give the application permission to place a phone call. Open the project options by right-clicking

Phoneword in the Solution pad and selecting Options:
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In the Project Options dialog, select Build > Android Application. In the Required Permissions section,

enable the CallPhone permission:

16. Save your work and build the application by selecting Build > Build All (or by pressing ⌘⌘ + B). If the

application compiles, you will get a success message at the top of Xamarin Studio:

If there are errors, go through the previous steps and correct any mistakes until the application builds

successfully. If you get a build error such as, Resource does not exist in the current context, verify that the

namespace name in MainActivity.cs matches the project name (Phoneword) and then completely rebuild

the solution. If you still get build errors, verify that you have installed the latest Xamarin.Android and

Xamarin Studio updates.
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17. Now that you have a working application, it's time to add the finishing touches! Start by editing the Label

for MainActivity. The Label is what Android displays at the top of the screen to let users know where

they are in the application. At the top of the MainActivity class, change the Label to Phone Word as

shown here:

namespace Phoneword

{

    [Activity (Label = "Phone Word", MainLauncher = true)]

    public class MainActivity : Activity

    {

        ...

    }

}

18. Next, set the application icon. Open the downloaded and unzipped Xamarin App Icons set. Expand the

drawable-hdpi folder under Resources and remove the existing Icon.png by right-clicking it and selecting

Remove:

When the following dialog box is displayed, select Delete:

/guides/android/getting_started/hello,android/Resources/XamarinAppIconsAndLaunchImages.zip
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19. Next, right-click the drawable-hdpi folder and select Add > Add Files:

20. From the selection dialog, navigate to the unzipped Xamarin App Icons directory and open the drawable-

hdpi folder. Select Icon.png:
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21. In the Add File to Folder dialog box, select Copy the file into the directory and click OK:

22. Repeat these steps for each of the drawable- folders until the contents of the drawable- Xamarin App

Icons folders are copied to their counterpart drawable- folders in the Phoneword project:

These folders provide different resolutions of the icon so that it renders correctly on different devices with

different screen densities.
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23. Finally, test the application by deploying it to an Android emulator. In Xamarin Studio, select a virtual device

(under Virtual Devices) and click the play button in the upper left corner:

As shown in this screenshot, the Nexus 4 (KitKat) (API 19) virtual device was selected.

24. After Xamarin Studio loads the application into the virtual device, the Phoneword app is automatically

started. The screenshots below illustrate the Phoneword application running in an Android SDK emulator

configured as a Nexus 5 running Lollipop. Clicking the Translate button updates the text of the Call button,

and clicking the Call button causes the call dialog to appear as shown on the right:

[[/ide]]
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Congratulations on completing your first Xamarin.Android application! Now it's time to dissect the tools and skills

you have just learned. Next up is the Hello, Android Deep Dive.
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